Jump to content

187 posts / 41364 viewsLast Reply

Recommended Posts

14 minutes ago, iacas said:

Meh. I don't forget to tag shots, and that sounds like it could just be the gyroscope or whatever in your unit failing/getting old.

New unit last July.

 I’m mostly concerned that new problems have developed. Things that were functioning features aren’t functional anymore. When weather warms up this spring I’ll start using it again.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Register for free today and you won't see this ad spot again!

On 3/4/2019 at 10:33 AM, iacas said:

Wow.

That’s wretched. Please share the response.

I received a response from Game Golf Support:

Good afternoon James,

I’m sorry for the inconvenience. The medallion firmware need to be updated from .76 to 8.1.0.5.

Please ensure the tags are also up to date:

> Tap Pro

> Tag Manager

> Tap each tag to update firmware

Kind regards.


I did all of the above and after updating the medallion firmware it did not update to 8.1.0.5.

608076254_Screenshot_20190305-185037_GAMEGOLF1.jpg.3d426a2518f514bb1492b5b5af461528.jpg

I also re-paired all the club tags and the putter tag would not pair.

I sent them another response so we'll see what they come up with next.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

I've only been able to play one round with mine so far, and surprising after reading all the issues people are having it worked pretty well. It did not pick up putts very well mostly tap-ins are the ones i had trouble with. I am used to having to go back and move the flag stick though after every hole so, I was able to check my putts and fix them at the same time anyway. The app also has a feature now after every hole you confirm your number of putts anyway. The biggest issue I had was for some reason on the last hole it just shut off, idk if I accidentally hit the power button or something but I had to log that hole manually because by the time I noticed it I was done with the hole.

I was on the latest firmware  and tag firmware before I played so anyone having issues make sure you update all that stuff, which is a pita because you have to do each tag on it's own, it would be nice to be able to update it all at one time or for them to do it automatically.

As far as no longer tagging it was great, I did not mind tagging at all before but once I got used to not doing it, it just seems like so much less hassle.

On 3/5/2019 at 10:46 PM, coachjimsc said:

I received a response from Game Golf Support:

Good afternoon James,

I’m sorry for the inconvenience. The medallion firmware need to be updated from .76 to 8.1.0.5.

Please ensure the tags are also up to date:

> Tap Pro

> Tag Manager

> Tap each tag to update firmware

Kind regards.


I did all of the above and after updating the medallion firmware it did not update to 8.1.0.5.

608076254_Screenshot_20190305-185037_GAMEGOLF1.jpg.3d426a2518f514bb1492b5b5af461528.jpg

I also re-paired all the club tags and the putter tag would not pair.

I sent them another response so we'll see what they come up with next.

Did you try closing the gg app and see if the app refreshed to display correctly?

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

1 minute ago, Slowcelica said:

As far as no longer tagging it was great, I did not mind tagging at all before but once I got used to not doing it, it just seems like so much less hassle.

I don't mind tagging, I've gotten used to it now, and with all the issues that have been shared so far, the cons of using GG Pro not tagging seem to outweigh the pros, IMO.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

7 minutes ago, klineka said:

I don't mind tagging, I've gotten used to it now, and with all the issues that have been shared so far, the cons of using GG Pro not tagging seem to outweigh the pros, IMO.

See I felt the same way until I played around without having to tag at all. Hopefully they get all the issues worked out soon.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

17 minutes ago, Slowcelica said:

I was on the latest firmware  and tag firmware before I played so anyone having issues make sure you update all that stuff, which is a pita because you have to do each tag on it's own, it would be nice to be able to update it all at one time or for them to do it automatically.

That you have to update the firmware on your tags is, IMO, pretty stupid.

5 minutes ago, Slowcelica said:

See I felt the same way until I played around without having to tag at all. Hopefully they get all the issues worked out soon.

You also had to check the number of putts you made after EVERY hole. That alone is enough to make me like my Classic/LIVE more so than this, and that's without any of the problems you've had.

Plus the swing weight change from the Pro tags.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

3 minutes ago, iacas said:

That you have to update the firmware on your tags is, IMO, pretty stupid.

You also had to check the number of putts you made after EVERY hole. That alone is enough to make me like my Classic/LIVE more so than this, and that's without any of the problems you've had.

Plus the swing weight change from the Pro tags.

Well again, I move the flag to the correct location after every hole anyway so for me it is a non issue, it's better than having to go back at the end of the round and try to remember where the flag was. And it is a popup in the app that says confirm you had x number of putts on hole whatever, again not a big deal. You also don't have too, you can go and review at the end of the round like you would with classic or non-live.

Ya updating the tags suck, but i doubt once they get everything settled and stable you will have to update the tags very often.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

33 minutes ago, Slowcelica said:

Did you try closing the gg app and see if the app refreshed to display correctly?

They told me to re-install the app, which I did. The firmware is now up-to-date. It loaded another 6 holes after I did that. They were still all screwed up though.

The putter tag will not pair so they are sending me a new one. 

I'll be playing tomorrow, hopefully I'll get the tag tonight.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

47 minutes ago, Slowcelica said:

Well again, I move the flag to the correct location after every hole anyway so for me it is a non issue, it's better than having to go back at the end of the round and try to remember where the flag was. And it is a popup in the app that says confirm you had x number of putts on hole whatever, again not a big deal. You also don't have too, you can go and review at the end of the round like you would with classic or non-live.

You also said it missed a good number of your putts.

That alone is a total pain. So even under your somehow nearly perfectly working circumstances, it wouldn't be favorable for me. Tagging is a non-event, and by tagging… it doesn't miss things. Nor do I need to look at my phone after every hole to make sure nothing was missed.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

1 hour ago, iacas said:

You also said it missed a good number of your putts.

That alone is a total pain. So even under your somehow nearly perfectly working circumstances, it wouldn't be favorable for me. Tagging is a non-event, and by tagging… it doesn't miss things. Nor do I need to look at my phone after every hole to make sure nothing was missed.

Perfect it was not, but my experience is far from the thing doesn't work at all. Of the putts it missed they were probably 90% tap in putts it missed. According to others who have multiple rounds under their belt, it gets better with registering shots, as far as approach shots or drives I cannot remember it missing any.  Again I'm used to checking and moving the flag anyway so checking the number of putts were correct and adding in a tap-in here or there was not a big deal. I guess to each their own, you don't mind tagging, I thought I didn't either until I didn't anymore lol.

2 hours ago, coachjimsc said:

They told me to re-install the app, which I did. The firmware is now up-to-date. It loaded another 6 holes after I did that. They were still all screwed up though.

The putter tag will not pair so they are sending me a new one. 

I'll be playing tomorrow, hopefully I'll get the tag tonight.

I hope once you play a round with the updated firmware and new putter tag it works better.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

https://thesandtrap.com/forums/topic/77065-post-your-game-golf-rounds/?do=findComment&comment=1426757

Played first round after updating the app. Still haven't received the new putter tag.

It was improved. Got 7 of the 9 holes this time. Missed one chip shot and two tee shots. I'm going to hold off final judgement until I get the putter tag paired and see how it works. 

I did find it easier to edit my round on the phone instead of the computer.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

I've been using gamegolf since 2014 but may give up.  Early last year the app started draining the battery incredibly fast.  They let me download a beta of the next version and then it worked fine.  Probably used it more last year than ever before. 

But towards the end of 2018 to early 2019, it stopped working reliably--it wouldn't charge, sometimes seemed to charged but wouldn't turn on, other times stopped working mid-round. 

A few weeks ago I bought a new live unit on ebay.  It worked fine for a few rounds.  Then I had a round where it tracked all my shots, but completely scrambled them.  Shots on holes 9-11 were showing up as shots on the first hole.   At least it tracked the spots so I could fix it afterwards.

Next time out it didn't recognize/buzz when I tagged a club.  Fully charged.  Tried restarting.  Never seen that before.

Then the next time out, yesterday, it seemed to be tagging fine but I wasn't checking the app as I normally do after each hole.  I actually didn't check the app once, just trusted that the buzzing was working and I could fix any errors at the end.  But then I got to the end of the round and none of the strokes showed up.

I'm sure I could contact tech support again and maybe figure out a way to make it work.  But its just getting to the point where I'm spending too much time trying to get it to sync or otherwise work properly. 

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

4 hours ago, dsc123 said:

I've been using gamegolf since 2014 but may give up.  Early last year the app started draining the battery incredibly fast.  They let me download a beta of the next version and then it worked fine.  Probably used it more last year than ever before. 

But towards the end of 2018 to early 2019, it stopped working reliably--it wouldn't charge, sometimes seemed to charged but wouldn't turn on, other times stopped working mid-round. 

A few weeks ago I bought a new live unit on ebay.  It worked fine for a few rounds.  Then I had a round where it tracked all my shots, but completely scrambled them.  Shots on holes 9-11 were showing up as shots on the first hole.   At least it tracked the spots so I could fix it afterwards.

Next time out it didn't recognize/buzz when I tagged a club.  Fully charged.  Tried restarting.  Never seen that before.

Then the next time out, yesterday, it seemed to be tagging fine but I wasn't checking the app as I normally do after each hole.  I actually didn't check the app once, just trusted that the buzzing was working and I could fix any errors at the end.  But then I got to the end of the round and none of the strokes showed up.

I'm sure I could contact tech support again and maybe figure out a way to make it work.  But its just getting to the point where I'm spending too much time trying to get it to sync or otherwise work properly. 

I’ll reply over in the other thread, since this thread is for the pro version, and you and I are having issues with Live. 

 

Edited by Missouri Swede

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

On 3/18/2019 at 5:34 PM, Missouri Swede said:

I’ll reply over in the other thread, since this thread is for the pro version, and you and I are having issues with Live. s

 

Swede, are you running mojave on mac?  My live hasn't worked since apple updated to mojave, gg has reccomended everything from deleting and repairing to hard reset of my iPhone!  In november I lost the ability to upload to my mac, january I couldn't bt transfer to iPhone still trying to get it fixed.  I have uploaded logs and sent all sorts of screenshots to no avail very frustrating to not even get 6 months out of a piece of tech

Share this post


Link to post
Share on other sites

6 hours ago, G-off said:

Swede, are you running mojave on mac?  My live hasn't worked since apple updated to mojave, gg has reccomended everything from deleting and repairing to hard reset of my iPhone!  In november I lost the ability to upload to my mac, january I couldn't bt transfer to iPhone still trying to get it fixed.  I have uploaded logs and sent all sorts of screenshots to no avail very frustrating to not even get 6 months out of a piece of tech

To be clear that was not Apple's fault - it's GAME GOLF being lazy. They didn't update their Transfer app to support 10.14.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

22 minutes ago, iacas said:

To be clear that was not Apple's fault - it's GAME GOLF being lazy. They didn't update their Transfer app to support 10.14.

I realize this is all on game golf, the best part was when cs told me to do a hard reset of my phone to try and clear up problems with their app........

Share this post


Link to post
Share on other sites

I was an Arccos user and recently given it up.  I tried to use my Apple Watch linked to the software and the yardages were way off.  It made me question all the data.  That along with all the extra shots it seemed to add around the green and I had had enough.

I see Game Golf came out with a "Pro" unit.  I have found some internet chatter and none of it was good about both the hardware and the company.  Has anyone tried this?

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

2 hours ago, inthecup said:

I was an Arccos user and recently given it up.  I tried to use my Apple Watch linked to the software and the yardages were way off.  It made me question all the data.  That along with all the extra shots it seemed to add around the green and I had had enough.

I see Game Golf came out with a "Pro" unit.  I have found some internet chatter and none of it was good about both the hardware and the company.  Has anyone tried this?

I haven't tried Game Golf Pro but the initial reviews weren't real positive.   I can vouch for Game Golf Live.   It works well.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

Welcome to TST! Signing up is free, and you'll see fewer ads and can talk with fellow golf enthusiasts! By using TST, you agree to our Terms of Use, our Privacy Policy, and our Guidelines.

The popup will be closed in 10 seconds...