post #1 of 1
Thread Starter 

Hey guys i really need some help...

 

I'm struggling with something recently that I  have never really had trouble with before.  

I made some swing changes that upped my ball speed with my driver from 154 to 161 plus on trackman.

This swing i am producing an average of 3.8 degrees upward attack...neutral face angle to a very slight draw with in an in to out .5 to 1 degree club path.  Dynamic loft is 14.5 degrees

Driver spec is 8.5 degree static loft driver with a 2.5 degree open face at address

I am using a 75 gram Martrix black tie shaft that is fairly low torque ...3.2 or 3.3 i think.  Stiff shaft and a Razr fit extreme head set at 8.5 degrees and 1 degree open.   

I strike the ball just above center and very slightly toward the toe almost every time ...

I am fitting at an Edwin watts here on a track man and using their callaway hex chrome balls for the fitting.  Checked my numbers on both of thier units and found identical results.  and my buddy was hitting with me with the same driver and his numbers were very similar but with much lower spin.  So the trackman units are probably fine.

I went from 2400 -2500 spin and poor contact to this new setup and everything seems to be in line....except now my spin rates on every clubi have is spinning up

driver is now averaging 3600 rpm 

if my dynamic loft is 14.5 and AOA is 3 then my spin loft is 11.5  which should be perfect.  So one question i have is that since my spin loft is fine making adjustments to the shaft wont help...correct?...Alll i can do is hit more up at the ball switch driver heads and balls ...right?  I don't know and am pretty frustrated right now.  Gained all the speed but no distance in the end.

 

I would really appreciate some knowledgeable advice on what might be happening in this swing.

 

thanks 

 

Adam

exhibit A.