• Announcements

    • iacas

      Visit FlagstickRule.com   03/13/2017

      Visit the site flagstickrule.com to read about and sign a petition for the USGA/R&A regarding the one terrible rule in the proposed "modernized" rules for 2019.
Sign in to follow this  
Followers 0
saturday

Proforce V2

6 posts in this topic

I've had this shaft in my RBZ driver for a little over a month now and really liked it till I heard a weird crack sound today while on the 9th hole. It's a 77g stiff shaft and now it feels whippy like a women's flex...... Has anyone encountered this problem before? Golf town is willing to replace it but I'm edging even closer to getting my 913 D2 with diamana whiteboard 72g. I had read great reviews about the proforce v2 but I can't say I'm impressed with it cracking so quickly....
0

Share this post


Link to post
Share on other sites

Sign up (or log in) today! It's free (and you won't see this ad anymore)!

Sign up (or log in) today! It's free (and you won't see this ad anymore)!

I dunno. I have one in a Nickent Ironwood 3dx 3 hybrid and absolutely love it. However I might feel different if it cracked on me...
0

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

I dunno. I have one in a Nickent Ironwood 3dx 3 hybrid and absolutely love it. However I might feel different if it cracked on me...

Yeah true. I really was impressed with it until this happened. Guess it could happen to any shaft really.

0

Share this post


Link to post
Share on other sites

Maybe it was damaged when it was installed/cut. Seems a bit odd they have a good rep.
0

Share this post


Link to post
Share on other sites

I have the V2 in my irons, driver, and 5 hybrid.  No problems so far, and the best choice that I've ever made in a shaft.  Since i imagine that QC is good at the factory something must have happened during installation.

0

Share this post


Link to post
Share on other sites

Maybe it was damaged when it was installed/cut. Seems a bit odd they have a good rep.

Yah you're right. I spoke to the guys today and turns out they installed it incorrectly.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0