Sign in to follow this  
Followers 0
juanrjackson

uPro Issue/problem

5 posts in this topic

All,

Last weekend (7/25) I used my uPro & I the battery ran out. I put it on the charger when I went home, but when I went use my uPro this past weekend it would not turn on. I took out the battery for a few secs & then put it back in. When I push the "on button" the light blinks but it doesn't turn on.

I think it might be time for a new battery. Anyone else had this problem?

Thanks!
0

Share this post


Link to post
Share on other sites

Want to get rid of this advertisement? Sign up (or log in) today! It's free!

I just had the same problem with my uProGO and it's only a couple months old. I haven't contacted anyone just yet but it sounds like we're in the same boat.
0

Share this post


Link to post
Share on other sites

I just had the same problem with my uProGO and it's only a couple months old. I haven't contacted anyone just yet but it sounds like we're in the same boat.

Redstar2112: I just wanted to let you know I contacted uPro & they told me to send it back in. They even emailed me the postage to mail it back. They are going to fix it for free or send me a refurbished one. Plus they are going to send me the new update for free too. Thanks!

0

Share this post


Link to post
Share on other sites

possibly unrelated, but the issue i encounter frequently with my Upro is the 3 blinking lights of death. It's when three of the four red lights turn on the main screen when you boot it up, but it never gets to the fourth and it continually reboots. This is caused by when the memory card gets loose, all you need to do it push it in(so it pops out), and then push it back in so it clicks in. This fixes it every single time
0

Share this post


Link to post
Share on other sites

possibly unrelated, but the issue i encounter frequently with my Upro is the 3 blinking lights of death. It's when three of the four red lights turn on the main screen when you boot it up, but it never gets to the fourth and it continually reboots. This is caused by when the memory card gets loose, all you need to do it push it in(so it pops out), and then push it back in so it clicks in. This fixes it every single time

My problem was similar...the 3 blinking lights of death. When I called Callaway, the tech ran me through some troubleshooting steps that included trying to get the memory card reset but it did not work. That is finally while he said to just send it back in.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0