Jump to content
mvmac

FlightScope Mevo - Portable Launch Monitor for the Everyday Golfer

281 posts in this topic Last Reply

Recommended Posts

How do you tell when it's fully charged? The blue bars just do the, one, two three bars repeat. It doesn't seem to illuminate all blue bars when done because I think I let it go overnight and it was doing the same thing. Memory is fuzzy though.

When leaving, easy to forget to turn off BT and phone and Mevo are still probably polling each other.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Want to hide this ad? Register for free today!

8 hours ago, b101 said:


The SW stats definitely show what I thought in the other thread - launch angle is your massive variable. 

P.S. I'll post my 3W too when mine arrives - that club goes all over the place. Currently, my Mevo package is still bouncing around every post office in New York...!

Thanks, and I think it's a sequence issue, but that remains to be seen. At least that's what I'm hoping will fix what I think is hitting fat which is causing "all over the map" launch angle issues? We'll see. . .

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

12 minutes ago, nevets88 said:

When leaving, easy to forget to turn off BT and phone and Mevo are still probably polling each other.

If the Mevo app is quit or not even the front-most app, it'll disconnect and the Mevo will power down/shut off.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

3 minutes ago, iacas said:

If the Mevo app is quit or not even the front-most app, it'll disconnect and the Mevo will power down/shut off.

Great, so I can just forget about it.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

1 minute ago, nevets88 said:
5 minutes ago, iacas said:

If the Mevo app is quit or not even the front-most app, it'll disconnect and the Mevo will power down/shut off.

Great, so I can just forget about it.

On my unit it takes about 2 to 3 minutes, and not 1 minute. I timed it in my lab while waiting for some stuff to compile. . .Once you get to the behavior of the Mevo it's actually quite a pleasant device to use. Loving it.

Edited by Lihu

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

The stickers are messy, they don't work well in pockets. Have to keep in a flat place, like wallet.

I forgot them one time and I think I was getting similar numbers.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

2 hours ago, nevets88 said:

The stickers are messy, they don't work well in pockets. Have to keep in a flat place, like wallet.

I forgot them one time and I think I was getting similar numbers.

I watched some video reviews on line and one person takes the large roll he bought and cuts them into 4 inch strips. Then he put the stickers on all the balls he wanted to monitor and set those balls aside while warming up. I forgot where the video was, but I thought the idea was good. Then he could put the stickers back into his bag.

Erik's review noted that outdoors with the 7 foot distance you don't need the stickers.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

38 minutes ago, Lihu said:

I watched some video reviews on line and one person takes the large roll he bought and cuts them into 4 inch strips. Then he put the stickers on all the balls he wanted to monitor and set those balls aside while warming up. I forgot where the video was, but I thought the idea was good. Then he could put the stickers back into his bag.

Erik's review noted that outdoors with the 7 foot distance you don't need the stickers.

The 2 strips that come with the Mevo are smaller than 4 inches. They're just not meant to be bent. 

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Anyone else having issues with the firmware updates taking forever? The first two I did went by really fast. The last one I did took about 45 minutes. I'm currently in the middle of one, it's going on an hour and a half. It's at 33% right now.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

27 minutes ago, DeadMan said:

Anyone else having issues with the firmware updates taking forever? The first two I did went by really fast. The last one I did took about 45 minutes. I'm currently in the middle of one, it's going on an hour and a half. It's at 33% right now.

Not forever, but It started just as I was getting my driver out yesterday. Which is why I didn’t get any data on that club.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

6 hours ago, DeadMan said:

Anyone else having issues with the firmware updates taking forever? The first two I did went by really fast. The last one I did took about 45 minutes. I'm currently in the middle of one, it's going on an hour and a half. It's at 33% right now.

I've had two so far that were quick.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

6 hours ago, Lihu said:

Not forever, but It started just as I was getting my driver out yesterday. Which is why I didn’t get any data on that club.

 

1 minute ago, mvmac said:

I've had two so far that were quick.

Another one at home.

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Note that if you force the update it’ll always apply it. I had a very fast one last night but I think that just fuenliads it to the phone. Then it actually applies it to the device which took 8 minutes roughly?

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

The update I did yesterday took about 4 hours in the end. Maybe it's because there were multiple updates? I haven't used the Mevo in about 2 weeks, so that could be part of it. I don't know. It was odd. 

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Looks like outdoor practice is back on the menu boys! Will be nice to see ball flight and numbers at the same time.

Screen Shot 2017-12-17 at 3.38.31 PM.png

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

This is very odd. Had that 4 hour firmware update yesterday. I'm now on my second firmware update today. First one was quick. Second one just started. I don't get why I've had 3 firmware updates in the past 2 days. I used the Mevo fairly often in November, so I shouldn't be this far behind on updates?

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

1 hour ago, DeadMan said:

This is very odd. Had that 4 hour firmware update yesterday. I'm now on my second firmware update today. First one was quick. Second one just started. I don't get why I've had 3 firmware updates in the past 2 days. I used the Mevo fairly often in November, so I shouldn't be this far behind on updates?

Are you sure they’re not being forced? Failing to complete? What version are you on?

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

22 minutes ago, iacas said:

Are you sure they’re not being forced? Failing to complete? What version are you on?

They're definitely not being forced. I'm pretty sure they're completing, at least the Mevo App says they are. I'm on the App version 1.2.12. Firmware version says 0.08 (top) and 1.08 (bottom). 

Share this post


Link to post
Share on other sites
Awards, Achievements, and Accolades

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×

Important Information

Welcome to TST! Signing up is free, and you'll see fewer ads and can talk with fellow golf enthusiasts! By using TST, you agree to our Terms of Use, our Privacy Policy, and our Guidelines.

The popup will be closed in 10 seconds...